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WinX program can communicate with all Nokeval devices 
supporting SCL-protocol, such as the 16-channel 
transmitter 5020SC, or the one-channel transmitter 7100. 

Connections 
Nokeval devices support RS-232 or RS-485 interface with 
the data acquisition system. RS-485 is recommended. 

RS-232: 

• Point-to-point bus. 
• Only one device can be connected to the bus. 
• Maximum cable length 15 m. 

RS-485: 

• Multipoint bus. 
• Up to 31 devices can be connected to the bus 

segment. 
• Maximum cable length without repeaters 1200 m. 

WinX supports serial (RS-232) ports and TCP (Ethernet) 
ports (option) directly. 

You can use different kinds of converters with WinX if 
they act as serial or TCP ports to the computer. 

• RS-232/RS-485 converters 
(Nokeval 711 and 721) 

• USB/RS-232 or RS-485 converters 
(ATEN UC-232A). 

• Ethernet / RS-232 or RS-485 converters 
(W&T ComServer). 

Data import 
WinX can import data from analog and digital input 
devices and other computers running WinX in the Slave 
mode (option). 

WinX inquires for measuring and digital input data from 
the devices by sending a command string to a device 
and then it waits for a response. 

Data can be imported from a device by one channel at a 
time or by groups of several consecutive channels. 

Data presentation 
Collected data can be presented on digital displays, 
bargraph displays or on trend graphs. 

Data save 
Collected data can be saved to files by data loggers. 

Data export (Option) 
WinX can export data to analog and digital output devices 
and to displays (a future feature). 

Demo program 
Without a software protection dongle, WinX will only run 
in demo mode. Random values will be generated instead 
of imported values. This way you can try and use the 
program without any devices. 

You can change the demo program to a real data 
acquisition system by ordering measuring instruments 
and the dongle (software security key). 

Versions 
Standard WinX includes 

8, 16, ... or 96 channels 

Digital displays 

Trend plots 

Bar displays 

Data loggers 

Statistical tracking 

Options 

Modem communication 

TCP/IP communication 

Slave mode, allows other WinX programs to read data. 

Data export 

GSM functions 

Hardware Requirements 
Minimum 

Pentium 90 MHz 
Windows 95 
32 MB RAM 
5 MB hard disk space 
CD-drive 
display 1024*768 
1 Parallel- or USB-port 
1 serial port (RS-232) 

Recommendation 
Pentium 200 MHz or faster 
Windows 2000 or newer 
64 MB RAM or more 

Introduction 

Software Package 
Nokeval Software CD 

WinX-program 
Drivers for software security key 
Configuration programs MekuWin and WinConf 
Set of utility programs 

Software security key 
Parallel port key as default 
USB-port key available 
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WinX can be connected to external devices or other 
computers via a serial port (RS-232), modem or TCP 
port. WinX accepts eight serial ports and four TCP ports. 

WinX can also read measuring data from other computers 
and allow other computers to read its own measurement 
values. 

The RS-232 port only accepts the connection of one 
device. With the help of a serial converter RS232-RS485, 
it is possible to increase the number of devices that can 
be connected to the port. The standard RS-485 port 
accepts 31 devices. Nokeval serial converters 711 and 
721 have two RS-485 ports which enables the connection 
of as many as 62 devices to one RS-232 port of a PC. 

Network Communication 
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The RS-485 bus is a chain by topology. A termination 
resistor 100-120 ohm has to be installed at both ends of 
the chain. Additionally, it is recommedable to have Fail 
safe resistors on the bus, which will keep the bus in the 
desired mode when there is no communication on the 
bus. The best result will be reached by using shielded 
twisted wire. 

The easiest way to create a RS-485 bus for a standard 
PC is to use an RS-232/RS-485 converter, for example 
the Nokeval models 711 or 721. These models have built- 
in termination and Fail safe resistors. Add-on RS-485 
cards to the PC are not recommended as Nokeval cannot 
guarantee their compatibility with the WinX software. 

RS-485 cable is connected from device to device 
(chain topology). 

Only short branches of cable, less than 2 m, are 
acceptable. 

Typical connections for multi-channel transmitters ( 16 channels / transmitter 5020SC) 

Connecting Devices to Serial Bus RS-485 
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Installation 
The installation program starts automatically when 
Nokeval Software CD is inserted into the CD drive. If 
not, start installation program startup.exe directly from 
the CD-ROM. Select WinX 1.0.xx by option buttons. 

Installing WinX 
Click the WinX button to start the WinX installation 
program.  A dialog window appears as below. 

If necessary, you can change the installation directory. 
Click the Finish button to complete the installation. 

You are able to run WinX in demo mode without the 
software security key and also without installing SuperPro 
Drivers. The demo mode is otherwise fully functional, but 
measuring values are generated by the software instead 
of reading actual devices. 

Installing SuperPro Drivers 
Press the SuperPro Drivers button to start the Sentinel 
System Driver installation program. A dialog window 
opens as below. 

Continue by clicking Next >. This will open the License 
agreement window. 
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Accept the terms in the license agreement and click Next 
>. This will open the Setup Type window. 

Select the setup type: 

Complete will install drivers for the Parallel port and USB 
port dongles. 

Custom will allow you to select which driver to install. 

Continue by clicking Next >. This will open the Ready to 
install window. 

Start to install Sentinel SuperPro drivers by clicking Install. 

After the installation is completed, exit InstallShield Wizard 
by clicking Finish. 
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Using WinX 

Start WinX 
Make sure you have a software protection dongle installed 
on a parallel port or USB port. Click the Start button on 
the Windows toolbar, select Programs > Nokeval > 
WinX. WinX will check the existence of SuperPro drivers 
and dongle. 

If the driver cannot be found, you will see the message 
box above. You can continue in Demo mode, install the 
missing drivers or exit the WinX program. If you select 
Install, you will be asked to place the WinX CD into your 
CD-ROM drive. See section Installing SuperPro Drivers 
for detailed instructions. 

If the dongle cannot be found you will see the message 
box below. You can continue in Demo mode, search for 
the dongle again, or exit the WinX program. 

If you choose to search for the dongle again, you will be 
asked to check that your dongle is connected to the 
parallel or USB port. 

When starting up, WinX will load initialization files from 
the directory settings. If the initialization files cannot be 
found, WinX will create them with default settings. 

WinX will start in the same mode where it was when it 
was closed, also in case of a power failure. 

WinX Main Window 
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Menu Bar 
Login 

Here you can login with a password or logout to 
become a standard user (Everybody). See User 
login. 

Setup 
Here you can configure the WinX software. 
See Setup WinX. 

Tools 
Here you can configure or use your special tools. 
See Tools. 

View 
Here you can view Digital I/O Registers, Log files or 
Logger files. See View. 

Print 
Here you can print setting and measuring values. 
See Print. 

Help 
Here you can open the Help file, view information 
about your WinX or order more options to your 
WinX license. See Help. 

Indicator Bar 
Run 

Data acquisition in progress. 

Demo 
Demo mode. 

Error 
Communication error. 

Alarm 
Alarms in use. 

Logger 
Logging to file in progress. 

Statistics 
Statistical tracking in progress. 

Trends 
Trend plotting in use. 

BarDisp 
Bar graph displays in use. 

TCP 
A TCP connection to the program. 

GSM 
GSM modem initialized and ready. 

Info Bar 
Start Date 

Start date of data acquisition. 

Start Time 
Start time of data acquisition. 

Updated 
Start time of the latest data acquisition loop. 

Loop Time 
Duration of the data acquisition loop. 

Interval 
Interval between data acquisition loops. 

User 
Current user. 

Digital Displays 

Buttons 
Start 

Starts data acquisition. 

Stop 
Stops data acquisition. 

Sound On/Off 
Enables/Disables the use of a sound card in alarms. 

Alarms On/Off 
Enables/Disables alarms. 

Reset Alarms 
Resets all alarms. 

Statistics 
Opens the window for statistical tracking. 

Trends 
Opens the trend plot window. 

Logger 
Opens the data logger window. 

BarDisp 
Opens the bar display window. 

Quit 
Exits the WinX program. 
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User  Login 
With WinX it is possible to form users/ user groups with 
different kinds of user rights to the WinX software. When 
you start  WinX, you have the default user rights 
"Everybody". You can login as an Admin user,  (default 
password “0000”), who has the right to add and remove 
users, change their passwords and user rights. 

Login with a password 
Click Login menu > Login. Select the user or user group 
to login, type the password into Password and Click the 
Login button. 

Logout to become a default user 
Click Login menu > Logout. 
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Setup WinX 
Before you can use WinX, you have to set up some 
parameters for the program. 

General Setup 
You can enter general settings by selecting Setup > 
General on the WinX menu bar. Please note that you 
cannot open the Setup menu when data acquisition is 
running. 

In the General Setup window you can select how many 
channels, loggers,  trends plot groups, and bar displays 
are in  use, the alarm delay etc. If other software is used 
in the computer simultaneously, it is not recommendable 
to select more features than necessary. 

Channels 
The number of channels you want to use. The 
maximum number of channels is limited by your 
license. 

If you need more channels than you can select, fill in a 
license expansion form and send it to your supplier or 
Nokeval Oy. 

Communication Interval 
Communication Interval expresses the time in seconds 
how often WinX performs communication loops with the 
external devices. The interval can be selected from 1 to 
60 seconds. A typical  acquisition time from the 5020SC 
is about 0.9 sec. Do not set a shorter interval than 
necessary. 

If your mouse stops working or it works slower than 
normally, the communication interval may be too short, 
the computer acquiring data from the devices 
continuously, and there is no time for other functions. 

Data Loggers 
You can select the number of data loggers to be used 
from 0 to 8, i.e. you can use as many as 8 loggers at the 
same time. You can log the same data in different ways. 
For example one logger may log all the channels, the 
second logger only the channels of one furnace and the 
third logger the channels of another furnace. 

Trend Plot Groups 
You can select the number of trend plot groups you need 
from 0 to 12. One group can show up to 8 trends. The 
maximum number of trend plot groups depends on your 
license. 

Bar Display Groups 
You can select the number of bar display groups you need 
from 0 to 6. Each group can have up to 16 bar graphs. 
The maximum number of bar display groups depends on 
your license. 

Alarm Delay (samples) 
You can set a delay of  0 - 8 samples to alarms. This 
means that the value must stay in the alarm area for the 
time of maximum 8 extra samples before the alarm 
occurs. 
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Demo Mode 
You can use WinX in demo mode by selecting this 
check box. 

Sound Card 
You can take a sound card into use by this check box. 
The sound card can be used to express alarms. For a 
new sound effect, replace the Wowo.wav file by a file of 
your own choice. 

Alarm Log 
When Alarm Log is selected, all the events related to 
alarms are logged to AlarmLog.txt file, which is situated 
in the WinX subdirectory List. You can view this file by 
selecting the View menu > Alarm List. 
Error Log 
When Error Log is selected, all communication errors 
are logged to ErrorLog.txt file, which is situated in the 
WinX subdirectory List. You can view this file by selecting 
the View menu > Error List. 
GSM Log 
When GSM Log is selected, all the events related to  GSM 
communication are logged to GsmLog.txt file, which is 
situated in the WinX subdirectory List. You can view this 
file by selecting the View menu > GSM List. 
Logger Log 
When Logger Log is selected, all logger activities are 
logged to LoggerLog.txt file, which is situated in the WinX 
subdirectory List. You can view this file by selecting the 
View menu > Logger List. 
Enabled Options 

Support for Modems 
Enables communication through a telephone 
network. 

Support for TCP/IP 
Enables communication e.g. in a local network. 

Slave Support 
Makes it possible for other computers to read the 
data in this computer. 

Export Data 
Allows data to be transmitted to external devices. 
Measuring data can be converted to analog signals 
for example with the 4-channel transmitter 
7470RS. 

GSM Functions 
Support for GSM functions, enables e.g. the 
transmission of an alarm as a text message. 

Disabled Features 
Data Logger 

Prevents the use of data loggers. 

Advanced Logger 
Prevents the use of advanced data loggers (trigger 
start, etc.). 

Trend Plot 
Prevents the use of trend plots. 

Bar Display 
Prevents the use of bar displays. 

Staristics Display 
Prevents the use of statistics tracking. 

The subdued color of the check box indicates that the 
option or feature is disabled by your license. 
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Communication Setup 
WinX  program communicates with  external devices and 
programs through a serial communication port (RS-232, 
RS-485) or through a network (TCP/IP). 

WinX communication can be divided into three categories: 

Master Communication 
When WinX wants to communicate with external devices 
or computers, it functions as the Master. 

Slave Communication 
When an external device or a computer wants to 
communicate with the WinX software, the WinX has to 
support the Slave function. 

GSM Communication 
GSM communication function is applied when WinX 
sends/ receives an SMS message or makes an sound 
call through a GSM modem. 

How to set a COM port for Master use: 
First select the Port you want to add and activate the 
Use check box. 

When using an RS-232/RS-485 converter which echoes 
back the marks you send, activate the Echo check box. 
Then WinX will remove the echoed marks  from its receive 
buffer. 

Select the Baud rate for communication and connection 
Type. Alternatives for the Type are as follows: 

Direct Cable The devices are connected to the 
computer with a cable. 

Modem Single The devices are connected to the 
computer with modems over the telephone network. 
A call will be made to one number only. 

Modem Multiple The devices are connected to the 
computer with modems over the telephone network. 
Calls can be made to several numbers. 

If you are using any of the modem options, you have to 
define the initialization string (Init String) for your modem. 
In case you use a single dial modem, you also have to 
define the Number you want to dial. 

How to release a COM port from Master operation: 
First select the Port you want to release and deselect 
the Use check box. 

Tcp Port 
Here you can set up TCP ports for Master operations. 
You can use up to 4 TCP ports. 

How to set a TCP port for Master operation: 
First select the Port you want to set and then activate the 
Use check box. 

Type the IP Address and the IP Port  of the external 
device or computer. 

How to release a TCP port from Master operation: 
Select the Port you want to release and deselect the Use 
check box. 

Master Communication Setup 
When WinX works as the Master, it sends a command 
string to an external device or computer and remains 
waiting for a respond string. WinX can use as many as 8 
serial ports and 4 TCP/IP ports for communication. 

You have to define the Com Ports and Tcp Ports WinX 
uses for Master communication. 

You also have to define Import Commands to read data 
from devices and Export Commands to send data to 
devices. 

Com Port 
Here you can set up serial ports for Master operations. 
You can set maximum 8 serial ports. 
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Import Commands 
Data can be imported from many different sources, 
transmitters, digital input units, or other computers running 
the WinX software. Data can be imported through a serial 
port or a TCP port.  Before you define the import 
commands, make sure you have set up all the necessary 
COM and TCP ports. 

You can set up the command strings for measuring data 
(Input Channel) and binary data (Digital Inputs) in their 
own windows. 

WinX first performs the command strings for measuring 
data in the order in which they appear in the Command 
String List and then continues performing the command 
strings for binary data similarly. 

Command String Generator forms the commands to be 
sent to the devices according to your choices. The 
generated command string will be displayed in the 
Command String text box where you can check it before 
moving it over to the Command String List. 
How to add a command to the list: 
Set up the values related to the command. See the 
sections Measuring inputs and Binary inputs for details. 
Press Add in order to add the command at the bottom 
of the list or Ins to insert the command just before an 
activated row in the list. 

How to edit a command: 
Double-click the row that you want to change, make the 
corrections, and press Rep. 

How to remove a command: 
Select the row that you want to delete and press Del. 
Measuring inputs (Input Channel) 
WinX starts reading the measuring data in the order the 
commands appear in the Command String List. The 
first read channel in the first row will be displayed in 
channel 1 in the WinX main window. 

Command String Generator fields for measuring 
inputs: 
Connection The port through which communication with the 

device occurs. 
Address The serial communication address of the device. 
1. Ch The 1st channel of the device from which data is 

imported. 
Chs The number of  the channels from which data is 

imported. 

Binary inputs (Digital Input) 
WinX starts reading the binary data in the order the 
commands appear in the Command String List. The 
first read channel in the first row will come to the Digital 
Input channel 1 in WinX Digital I/O registers. See View/ 
Digital I/O. 

Command String Generator fields for binary inputs: 
Connection The port through which communication with the 

device occurs. 
Address The serial communication address of the device. 
1. Ch The 1st channel of the device from which data is 

imported. 
Chs The number of the channels from which data is 

imported. 
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Export Commands 
Data can be exported to several different targets, 
transmitters, digital output units, or digital displays via 
different ports. Before you define the export commands, 
make sure you have set up all communication ports 
according to the structure of your hardware. 

You can set up the export commands for measuring data 
(Output Channel), binary data (Digital Output) and 
display data (External Display) in their own windows. 

WinX first performs the command strings for measuring 
data in the order in which they appear in the Command 
String List and then continues performing the command 
strings for binary data and display data similarly. 

Command String Generator forms the commands to be 
sent to the devices according to your choices. The 
generated command string will be displayed in the 
Command String text box where you can check it before 
moving it over to the Command String List. 
How to add a command to the list: 
Set up the values related to the command. See 
Measuring Outputs, Binary Outputs and External 
Display . Press Add in order to add the command at 
the bottom of the list or Ins to insert the command just 
before an activated row in the list. 

How to edit a command: 
Double-click the row that you want to change, make the 
corrections, and press Rep. 

How to remove a command: 
Select the row that you want to delete and press Del. 
Measuring Outputs (Output Channel) 
WinX starts reading the measuring data in the order the 
commands appear in the Command String List. 

Command String Generator fields for measuring 
outputs: 
Connection The port through which communication with the 

device occurs. 
Address The serial communication address of the device. 
1. Ch The 1st channel of the device to which data is 

exported. 
Chs The number of the channels to which data is exported. 
Output Ch 01-08 WinX measuring channels to be exported. 

Binary outputs (Digital Output) 
WinX starts reading measuring data in the order the 
commands appear in the Command String List. 

Command String Generator fields for binary 
outputs: 
Connection The port through which communication with the 

device occurs. 
Address The serial communication address of the device. 
1. Ch The 1st channel of the device to which data is 

exported. 
Chs The number of the channels to which data is exported. 
Output Ch 01-08 WinX binary channels to be exported. 

External Display 
This feature not yet available. 
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Slave Communication Setup 
If WinX is in slave mode it waits for a command sent by 
an external device or a computer and responds to it. Slave 
communication can be established via a serial or TCP 
port. You have to set up the port for Slave communication. 

Serial Port 
If you want to share data of the WinX software via a serial 
port, select the Port and Baud rate. Otherwise select 
“None” to the Port. If you use a modem, activate the 
Modem check box and type the initialization string. 

TCP Port 
If you want to share WinX data via an ethernet network, 
activate the Use check box and type the IP Port. 
Otherwise deselect the Use box. 

Use free IP ports. Ports 0-1024 are generally in use and 
it is not recommended to use them. Ports 49152-65535 
are mostly free. It is advisable to select the IP port within 
this range to make the use of a reserved port as unlikely 
as possible. 
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GSM Communication Setup 
In WinX it is possible to send alarms by text messages 
(SMS) or by recorded sound messages. This option 
requires a GSM modem. 

To use this option you first have to set up a serial port 
(GSM Port) which you want to reserve for GSM 
communication. Additionally, you have to create the 
Phone Books on the basis of which the numbers are 
selected to which the alarms are sent. You also have to 
create the actual alarm messages (Alarms). 

GSM Port 
Select the com Port you want to allocate to the GSM 
modem. Or select “None” if you do not need any GSM 
function. Also select the Baud rate and type the 
initialization string (Init String) if needed. Activate the 
Open check box when you want to open the selected 
port. Deselect the Open box when you want to close the 
port. 

Phone Books 
These books list the numbers to which GSM alarms are 
sent. 

To create a new book click the Add Book button. Give a 
name to the book and fill in names and numbers in the 
Call List.You can edit the book by making changes in 
the Call List text boxes.To delete a book, click the Cut 
Book button. 

Alarms 
GSM Alarm Channel 

Select the GSM Alarm channel that you want to set 
up. 

Alarm Type 
Select the type of GSM Alarm: 

• None No alarm is sent. 
• Text A text message AlarmText is sent. 
• Voice A recorded sound message is sent. Note 

that this option requires a cable between 
the sound card and GSM modem. 

Phone Book 
Select the phone book that is used with this GSM 
alarm. In the text box below this selector you can see 
the names listed in the selected phone book. 

Messages to send instantly 
To how many numbers this alarm is sent instantly. 

Delay to next message if not quit 
How long will be waited for a response before the 
alarm is sent to the next receiver in the list. 

Delay to next alarm after quit 
How long will be waited after a response before 
the alarm is sent again. 

Remote confirmation 
Select how this alarm can be confirmed by the user: 

• Not allowed Alarm cannot be acknowledged this 
way. 

• SMS + password  Alarm can be acknowledged by 
sending a text message containing a 
password. 

• SMS Alarm can be acknowledged by sending a 
text message. 

• Call Alarm can be acknowledged by making a 
call. 
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Channel Setup 
Channel setup can be performed either in the Channel 
Setup Window or in the Display Setup Window. 

Channel Parameters 
Name 

The name of the channel, max 20 characters. 

Text * 
A longer description of the channel. You can see the 
description by double clicking the digital display in 
the WinX main window. 

Decimals 
Display accuracy of the channel. Please notice that 
the real measuring accuracy depends on the device 
that is read. 

Alarm1 Text * 
Description of the 1st alarm of the channel. 

Alarm1 Value 
Alarm value of the 1st alarm of the channel. 

Alarm1 Hysteresis 
Hysteresis of the 1st alarm of the channel. 

Alarm1 Alarm Register 
Alarm register for the 1st alarm of the channel. In 
WinX there are 16 alarm registers through which 
alarm information can be directed to external 
devices such as 7180. 

Alarm1 GSM Register 
GSM register for the 1st alarm of the channel. In the 
WinX there are 16 GSM registers through which 
alarm information can be directed via a GSM 
modem as text or sound messages. 

Alarm1 Type 
Type of the 1st alarm of the channel. 

LO_M Low limit with manual reset. 
LO_A Low limit with automatic reset. 
OFF Alarm off. 
HI_A High limit with automatic reset. 
HI_M High limit with manual reset. 

Alarm2 Text * 
A description of the 2nd alarm of the channel. 

Alarm2 Value 
Alarm value of the 2nd alarm of the channel. 

Alarm2 Hysteresis 
Hysteresis of the 2nd alarm of the channel. 

Alarm2 Alarm Register 
Alarm register of the 2nd alarm of the channel. See 
Alarm1 Alarm Register for further information. 

Alarm2 GSM Register 
GSM register of the 2nd alarm of the channel. See 
Alarm1 GSM Register for further information. 

Alarm2 Type 
Type of the 2nd alarm of the channel. See Alarm1 
Type for further information. 

Offset 
Offset correction for the value of the channel. 
Default 0.0 

Multiplier 
Multiplier for the value of the channel. Default 1.0 

Note! You can set parameters marked by * only in the 
Display Setup Window. 

Channel Setup Window 
Channel Setup window appears by selecting Setup > 
Channel on the WinX menu bar. Note that you cannot 
open the Setup menu when data communication is 
running. 

Changing settings: 
Activate the edit mode by double-clicking the cell or select 
the cell with the mouse and press F2. In the edit mode 
you can change the value in the cell. When editing, you 
can move from cell to cell by CTRL + arrow key. 
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In the columns Type1 or Type2 you cannot enter the edit 
mode. To change the values in the cells, use the following 
keys: 

L for LO_M 
l for LO_A 
o for OFF 
h for HI_A 
H for HI_M 

Display Setup Window 
The Display Setup window opens by right-clicking a digital 
display in the WinX main window. 

You can change the display to be set up by selecting the 
Display number. Set the parameter values, and select a 
new display, or click OK to exit. 
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User  Setup 
Users/ user groups can be added or deleted and user 
rights can be determined in the User Setup window. The 
window appears when you select Setup > Users. Please 
note that it is only the “Admin” user who has the right to 
open this window. 

How to add a new user/ user group: 
Select a User number with no name. Type the name of 
the user or user group, click Set Password, and type the 
passwords. 

How to change user rights: 
Select the number of the User whose rights you want to 
change. Add or remove the rights. 

Setup Rights 
General 

Right to set up general settings. 

Communication 
Right to set up communication settings. 

Channels 
Right to set up channel settings. 

Tools 
Right to set up the Tools menu. 

Logger 
Right to set up data logger settings. 

Trend 
Right to set up trend plot settings. 

Bar 
Right to set up bar display settings. 

Statistics 
Right to set up statistics settings. 

Control Rights 
Run 

Right to strat and stop data acquisition. 

Logger 
Right to start and stop loggers. 

Trend 
Right to start and stop trend plotting. 

Bar 
Right to start and stop bargraph displays. 

Statistics 
Right to start and stop statistical tracking. 

Tools 
Right to open the Tools menu. 

How to remove a user/ user group: 
Select the number of the User you want to remove. Click 
Clear User to remove the selected user. 
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View 
Here you can view the I/O registers, log files and logger 
files. 

Digital I/O 
You can view the status of the I/O registers by selecting 
the Digital I/O from the View menu. 

The registers are: 

Digital Input 
The import commands of binary inputs place the imported 
values in this register. These registers are used, among 
other things, for controlling the loggers. 

Digital Output 
The export commands of binary outputs take the values 
they send from this register. This register is used by the 
Alarm Register, for example. 

GSM Input 
This register is not currently in use. 

GSM Output 
GSM alarms occur on the basis of this register. If the 
register switches on, an alarm is sent. This register is 
controlled by the GSM register of the alarm function. 

Tools 
From the Tools menu you can start utility programs like 
the configuration program MekuWin. You can create you 
own menu by selecting Configure Tools... 

Configure Tools Menu 
In this window you can customize your Tools menu by 
creating, modifying or deleting items. 

Adding a menu line: 
Write in the Menu Text text box the text you want to see 
in the Tools menu. Write the full path to the utility program 
in the Command text box or select it by the Browse 
button. Write the arguments of your utility program in the 
field Arguments if any. Add the menu line into the Menu 
Content list by pressing the Add button. 

Editing a  menu line: 
Select the menu line you want to change by selecting it 
from the Menu Content list. Make the changes as needed 
and press the Replace button. 

Deleting a menu line: 
Select the menu line you want to remove from the Menu 
Content list and press the Delete button. 
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Alarm Log (Alarm List) 
If you have enabled the AlarmLog function in General 
Setup, all changes in alarm states are logged to the file 
List\AlarmLog.txt. 

When you select the Alarm List from the View menu, 
the file in question is opened in NotePad. 

Error Log (Error List) 
If you have enabled the ErrorLog function in General 
Setup, all errors in data communication are logged to the 
file List\ErrorLog.txt. 

When you select the Error List from the View menu, the 
file in question is opened in NotePad. 

GSM Log (GSM List) 
If you have enabled the GSM Log function in General 
Setup, all GSM events are logged to the file List/ 
GSMLog.txt. 

When you select the GSM List from the View menu, the 
file in question is opened in NotePad. 

Logger Log (Logger List) 
If you have enabled the LoggerLog function in General 
Setup, all changes in logger states are logged to the file 
List/LoggerLog.txt. 

When you select the LoggerList from the View menu, 
the file in question is opened in NotePad. 

Statistics Log (Statistics List) 
If the statistical tracking is on, the file List/StatisticsLog.txt 
is updated every time the tracking is stopped, or a new 
statistical tracking period starts. 

When you select the Statistics List from the View menu, 
the file in question is opened in NotePad. 

Logger Files 

As Text 
A logger file appears on the screen in ASCII format when 
you choose Logger > As Text from the View menu A 
window opens where you can choose a file to be opened 
in NotePad. 

The logger file appears in NotePad as in the picture below. 
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As Chart 
A Logger file can be displayed as a graphic chart when 
you choose  Logger > As Chart from the View menu. A 
window opens where you can select the file to be viewed. 
After the selection, press the LOAD button.A Logger Chart 
Viewer window will appear on the screen, see the picture 
at the bottom of the page. 

You can view up to 8 logged channels simultaneously by 
selecting each channel by the ChNumber selector. 
ChName shows the name of the selected channel and 
the digital display to the right of ChNumber shows the 
value of the channel at the cursor. With the Offset arrows 
you can move the graph of the channel upwards or 
downwards on the screen. 

You can move the cursor by clicking the chart. When the 
chart is selected, the cursor is highlighted. You can also 
use the arrow-keys of the keyboard to move the cursor. If 
all of your data is not shown in the chart, you can scroll 
the chart by moving the vertical and horizontal scroll bars. 

At the bottom of the chart window you can see time 
stamps for samples at the left and right edge of the chart 
and for the sample at the cursor. 

From the menu File you can select 

Load 
Imports a new logger file to Chart Viewer. 

Reload 
Updates the current logger file to Chart Viewer. If 
you are viewing the same file you are logging in, you 
will have the latest data in the chart as well. 

ReDraw 
Replots the chart using the data that has already 
been loaded to the chart. 

-button 

Opens the Help file. 

-button 

Prints the Chart Viewer window to a printer. 

-button 

Opens the Chart Viewer Setup Window. 

Time stamp at the 
left edge of the chart 

Time stamp at the 
right edge of the chart 

Time stamp at 
the cursor Cursor 

Ch Name 

Ch Number 

Ch value 
at the cursor 
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Chart Viewer Setup 
You can set up the X-axis to AutoScale mode, in which 
case all the samples are shown on the X-axis. You can 
also determine the number of samples to be displayed 
on the X-axis. The Y-axis can also be set to AutoScale 
mode. In this mode the Y-axis is scaled automatically so 
that all the minimum and maximum values of the selected 
channels will fit into the Y-axis. Alternatively, you can set 
the Maximum and Minimum values to the Y-axis. 

You can individually select the type of each trace to be 
either Thin Line or Fat Line. 

By clicking the Display Colors or Print Colors buttons, 
the Select Colors window will appear allowing you to 
choose the colors of the chart on the screen and for the 
printer. 

Selecting colors for Chart Viewer 
Select the item whose color you want to change from the 
list. Click the Color box in the bottom left corner to open 
the color palette. Select a color by clicking it. For the 
default colors, click Default. Accept the color changes 
by clicking OK or reject the changes by clicking Cancel. 

Help 

WinX has online help. You can open Context sensitive 

help by clicking  button (if there is one), the F1 key, 

or by selecting Help > WinX. 

Print 

You can print out general settings by clicking 
Print >Setup. 

To print measuring values click Print > Results. 
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Statistics 
You can keep track of the statistical values of the 
channels. The statistical values available are Min, Max 
and Mean. 

Tracking begins when the Statistics Start button is 
pressed and stops when the Statistics Stop button is 
pressed. The statistical values are saved to a file called 
StatisticsLog.txt on  disk whenever the tracking is stopped. 

If Daily Save is selected, the Statistics values are always 
saved to the file at midnight. At the same time a new 
tracking period is also started. 

Contents of the Statistics Window 

Informative fields: 
Start Date 

Start date of statistical tracking. 

Start Time 
Start time of statistical tracking. 

Samples 
The number of samples during the statistical 
tracking. 

Selectors: 
Daily Save 

Statistical values are saved to disk and a new 
tracking period is started every midnight. 

Buttons: 
Start 

Starts Statistics tracking. 

Stop 
Stops Statistics tracking. 

Close 
Closes the Statistics window. 

Prints the current statistical values. 

Opens the Help topic. 

Opens the StatisticsLog.txt file in NotePad. 
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Trend Plotter 
You can open the trend plot window by pressing the 
Trends button in the WinX window. Trends are shown in 
groups of two graphs each containing maximum four 
trends. The number of available trend groups depends 
on the number of channels in your license. For example 
in a 32-channel- version there are 4 groups. You can move 
from one group to another by selecting Trend Group in 
the upper-left corner. 

You can hide windows with the Hide button. Hide doesn’t 
end drawing but it closes the window onto the background. 

If you close the trend window by the Close button, drawing 
will start from the beginning when you open the Trends 
again. 

Select Trend Group 
to be displayed 
Time between samples Open Help topic 

Print Trend display 

Hide Trend display, 
continue plotting 

Close Trend display, 
clear the graphs Color Setup menu 

Time of the oldest sample 
in the graph 

Time of the newest sample 
in the graph 

Number of samples 
in the graph 

Open Trend 
Axis Setup 

Digital displays, right-click 
to open Trend Setup 
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Trend Color Setup 
From the Colors menu, you can change Trend graph 
colors separately for the display (Display) and the printer 
(Print). Especially with black and white printers, it is 
important to select  suitable colors to achieve the best 
possible readability. 

Trend Setup 
You can freely select any channel for any trend. Select 
the Trend Number you want to set up. Trends 1-4 are 
situated in the upper plotter and trends 5-8 in the lower 
plotter. Select the Channel number to be displayed in 
that trend and the style of the line (Trace Style). 

You can set up all the trends of the Trend Group at the 
same time, one after another, by changing the Trend 
number as required. Accept the settings by clicking the 
OK button. 

Trend Axis Setup 
You can set up the axes for each trend graph 
independently from each other. Define the maximum and 
minimum values for the Y-axis and the number of samples 
to be fitted onto the X-axis.Accept the settings by clicking 
the Set Axis button. Reject the new settings by clicking 
the Cancel button. 

Select the item for 
color change 

Open color palette to choose 
the color. 

Use default colors 
Accept color changes 
Cancel color changes 

Current color for the item 

Select Trend number. Select Trace Style. 

Select the channel 
number. 

Name of the selected channel 
Open Help topic 

Accept the settings 
Accept the settings Reject the settings 

Samples on X-axis 

Open Help topic Maximum value of Y-axis 
Minimum value of Y-axis 
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Loggers 
Logger function saves measuring data to disk in ASCII- 
format  for later survey. Data can be read into spreadsheet 
programs (Excel, Lotus, etc.) or it may be viewed in 
graphic format (ChartViewer). 

You can save measuring data by eight independent 
loggers. The channels which will be logged can be freely 
selected for each of the loggers. A particular channel can 
be selected for several loggers at the same time. The 
loggers can be started and stopped manually, on the basis 
of a trigger or timer. The Log Interval can be set as a 
multiple of the communication interval. 

Log Manager 

Name 
Name of the logger, e.g. Annealing furnace 1. 

Job Name 
Name of the job, e.g. Propeller. 

Job ID 
Identification code of the job, e.g. 1234-9999. 

Worker 
Name of the worker. 

-button 

Opens the Log Setup window. See the next page. 

Status 
Indicates the status of the logger. Possible statuses are: 

Stopped 
Logger is inactive. 

Idle 
Logger is active and waits for a trigger or timer 
event. 

Running 
Logger is active and saving data into file. 

Paused 
Logger is active but saving data into file is 
temporarily interrupted. 

Under the Status Box there is a ProgressBar indicating 
how full the current logger file is. 

Start/Stop 
Start / Stop the logger. Note; you cannot start or stop 
logger unless at least 1 channel has been selected for 
the logger. 

Open Help file 

Logger Number 
Logger Name Job Name Job ID Worker 

Open Logger Setup Logger Status 
File Status 

Start/ Stop 

button 
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Logger Setup 

Path Name 
The directory where logger files are saved. Change 
directories by clicking the button on the right side of  the 
Path Name text box. 

File Name 
Type the File Name without the file extension.  A 4-number 
index and the file extension (.TXT) will be automatically 
added to the file name. 

By selecting the Use default check box the file name is 
created automatically from the Log Manager fields Job 
Name & Job ID. 

First File Number (index) 
Select the index (0-9999) for the first logger file. When 
the first file is full, the next file is created with index 
increment by one. 

Log Period 
The multiplier for Log Interval. Log Interval can only be 
a multiple of the Communication Interval. The real log 
interval is shown in the Log Interval box. 

lionIntervaCommunicatLogPeriodlLogInterva *=

Samples / File 
You can select the number of samples (1-99999) to be 
saved to one file. The file size depends on the number of 
samples and channels. An estimation of the file size is 
shown on the right side of the text box Samples/File. 

Start Control 
Starting the Logger: 

Direct 
Logging starts instantly when the logger is started. 

Trigger 
Logging starts after the logger has been started and 
the Start Condition is true. 

Timer 
Logging starts after the logger has been started and 
the time set for the Start Timer is reached. 

Stop Control 
Stopping the Logger: 

Direct 
Logging stops instantly when the logger is stopped. 

Trigger 
Logging stops instantly when the logger is stopped 
or the Stop Condition Is true. 

Timer 
Logging stops instantly when the logger is stopped 
or the time set for the Stop Timer is reached. 

FileFull 
Logging stop instantly when the logger is stopped or 
the current logging file becomes full. 

Select the logger for setup 
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Pause 
Logging is interrupted until the Pause Condition is true. 

Average 
Average function can be activated if Log Period > 1. The 
mean value is calculated from the samples after the last 
saving. 

Start Condition 
Active if Start Control = Trigger. Click with the 
mouse to open Trigger Setup. 

Stop Condition 
Active if Stop Control = Trigger. Click with the 
mouse to open Trigger Setup. 

Pause Condition 
Active if Pause is selected as Active. Click with the 
mouse to open Trigger Setup. 

Start Timer 
Active if Start Control  = Timer. 
Starts the logging at the desired time on the desired 
date. Enter the day, month, year, hours, minutes 
and seconds. As the WinX uses the PC’s internal 
clock, make sure the time is right and remember the 
summer time (daylight saving time). 

Stop Timer 
Active if Stop Control = Timer. 
Stops the logging at the desired time on the desired 
date. Enter the day, month, year, hours, minutes 
and seconds. As WinX uses the PC’s internal clock, 
make sure the time is right and remember the 
summer time (daylight saving time). 

Channels 
Here you can select the channels you want to 
include in this logger. You can select or deselect a 
sequence of several channels from the logger at a 
time. Choose the first and the last channel whose 
selection you want to change, choose whether you 
want select or remove the channels and click the 
DO button. 

Channel Type 
Select the type of the trigger channel: Digital Input 
(binary input) or Input Channel (measuring input). 

Channel Number 
Select the number of the trigger channel. 

Compare 
Digital Input = 0 or 1. 
Input channel < Or > than the comparison Value. 

Value 
The value to which the Input Channel is compared. 

Logic Operation 
Logic operation between expressions. The 
operations available are: 

END 
No more expressions are included in the trigger 
function 

AND 
The next expression is included in the trigger 
function with logical AND. 

OR 
The next expression is included in the trigger 
function with logical OR. 

XOR 
Next expression is included to trigger function with 
logical XOR. 

Help button 
Opens the Help file. 

OKbutton 
Accepts the changes made in Trigger Setup. 

Cancel button 
Rejects the changes made in Trigger Setup. 

Trigger Setup 

Channel Type 
Channel Number Compare 

Value 
Logic Operation 
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Bargraph  Display 
The bargraph display window will appear when you press 
the BarDisp button in the WinX window. The bars are 
displayed in groups of 16 bars. The number of the groups 
available depends on the number of channels in your 
license. For example in the 32-channel version there 
are 2 groups available. You can move from one group to 
another through the Group selection spin box. 

Bar graph displays can visualize e.g. the temperature 

Select  the channel 
that is shown in this bar 

Set the maximum 
value for the bar 

Select the bar for 
setup 
1= on the left 
16= on the right 

Set  the same limit 
for all the channels 
at  the same time 

Set  the minimum 
value for the bar 

profile in a zone furnace. Temperature sensors are 
installed at regular distances from each other in the 
furnace. The bargraph shows the real time distribution of 
temperature in the furnace. Below each bar there is a 
digital display indicating the exact value of the channel. 
The channel to be displayed can be freely selected for 
each of the bars and the bars can be scaled independently 
from each other. 

In case of an alarm, the bar turns either blue or red 
depending on which alarm occurs. The alarms can be 
reset with the Reset button. 

Group selection 

Data acquisition in progress 
Print screen 
Start/Stop data acquisition Reset  alarms Scanning time between groups 

Close the window 
Hide the window 

Help 
Communication error 
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